Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: New MyLutron and software

  1. #1

    Angry New MyLutron and software

    Why do we have this new My Lutron portal with no way to get to programming software aside from clicking the My Lutron Classic button in the top left of the page? Is there another way to get directly to the software without jumping thru hoops?

    Also when I click the My Lutron Classic button in Chrome, it opens a new tab but the page never loads. It just keeps saying "Working" on the tab label, and it keeps trying to connect to https://umslogin.lutron.com/identity/...... (URL shortened). Its just constantly retrying and never connects. This works fine in Internet Explorer.

    I miss the old resi.lutron.com days...

  2. #2
    Super Moderator
    Join Date
    May 2013
    Posts
    420
    Hello johnmax,
    Thank you for your post.
    My myLutron view might be different, but you can try the route I take to download software. Login to your myLutron account. Hover your mouse over service and support then select design and configuration software. Scroll down on this page to then view all software you have access to. For legacy software, head back to service and support except this time select legacy products. Then in the drop down select the system.
    If this is not helpful or if you continue to experience connectivity issues, first try to clear your browser history, then restart the computer. If your issues persist, then send an email to mylutronsupport@lutron.com

  3. #3
    I dont think you are understanding my issue- I know how to find the software when the correct page actually loads... The first problem is when I am able to login, it takes me to a newer My Lutron Projects page- not the old one with all the links to click. I have to hit "My Lutron Classic" in the top left of page. See attached screen shot. It is unnecessary to go to the Projects page first. This was introduced somewhat recently.
    Click image for larger version. 

Name:	Capture.JPG 
Views:	23 
Size:	87.3 KB 
ID:	820

    My second problem is once I click the Classic link, the normal My Lutron page will never load if I use Chrome- it hasn't worked in months (It used to work). I have tried clearing browser and of course the computer has been restarted in that time. I'm surprised you didn't suggest to turn off my firewall :( . Whoever does your web development needs to have a look at this.

  4. #4
    Super Moderator
    Join Date
    May 2013
    Posts
    420
    Hello johnmax,
    I understand the issue now. I am not aware of this being a widespread issue, at least I don't recall hearing about it via phone/email. Does this issue persist on a different computer? If you haven't already please send an email to mylutronsupport@lutron.com. The folks who man that inbox can get your issue escalated to our web team.
    Thanks

Similar Threads

  1. concerned about myLutron requirement to use software
    By SparkyCoog in forum Troubleshooting - RA2
    Replies: 5
    Last Post: 03-01-2018, 11:20 AM
  2. MyLutron account?
    By AndyM in forum General Discussion - HWQS
    Replies: 1
    Last Post: 12-08-2017, 09:35 AM
  3. OTP MyLutron
    By Lukeetal in forum Troubleshooting - RA2
    Replies: 0
    Last Post: 05-06-2017, 09:30 PM
  4. mylutron.com is down?
    By digit1 in forum General Discussion - HWQS
    Replies: 2
    Last Post: 09-27-2016, 07:53 AM
  5. Is MyLutron site down?
    By David C. in forum General Discussion - HWQS
    Replies: 2
    Last Post: 09-17-2016, 08:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •