Thanks Thanks:  0
Likes Likes:  1
Dislikes Dislikes:  0
Results 1 to 3 of 3

Thread: Pd-6wcl stops working

  1. #1
    Junior Member
    Join Date
    Apr 2018
    Posts
    1

    Pd-6wcl stops working

    Installed this unit it worked for a week then it stop. It doesn't show power to switch. I disconnect all the wires and reconnected and worked again for 4 weeks. It stopped working again. How do I fix my problem?

  2. #2
    Senior Member
    Join Date
    Oct 2013
    Posts
    588
    There are a couple of possibilities.

    1. You could have a 3-way or 4-way switch somewhere that is occasionally being switched. This would isolate the load and make the dimmer act like it had no power.
    2. The minimum load is 1 LED or 25w of incandescent. If the dimmer is having problems identifying the load as LED (i.e. not on approved list) you would be below the minimum load.
    Element Integration
    5621-122 Departure Drive
    Raleigh, NC 27616
    www.elementintegration.com

  3. Likes Julia K. liked this post
  4. #3
    Authorized Lutron Contributor
    Join Date
    Jan 2018
    Posts
    107
    Hello Gearboys,

    Thank you for your post!

    randyc is very accurate here.

    Additional concerns are if you wired it live originally, this could have internally damaged the dimmer.

    Also if it is on a 3-way your original switch would have 3 screw terminals (not including the ground) and you would have 3 wires in your wallbox (not including the ground or neutrals if present).

    Another thing that could be causing the issue is any power surges/outages. These could confuse/damage the dimmer causing it not to function until re-powered.

    Please keep us posted on the status of the dimmer, if it continues to stop working, please call our 24/7 technical support line at 1-844-588-7661, to further assist you.

    Hope this helps!

    Julia K.

Similar Threads

  1. Pd-6wcl - no power at switch - lights working
    By Sonianic in forum Troubleshooting - CAS
    Replies: 2
    Last Post: 04-14-2017, 01:22 PM
  2. Defective PD-6WCL?
    By sobiloff in forum Troubleshooting - CAS
    Replies: 2
    Last Post: 11-07-2016, 10:08 AM
  3. Pd-6wcl 3way
    By Neilalp in forum Troubleshooting - CAS
    Replies: 3
    Last Post: 11-22-2015, 01:17 PM
  4. Old iPhone app stops working after processor replacement
    By DHKaplan in forum Troubleshooting - Legacy HW
    Replies: 2
    Last Post: 07-10-2014, 10:44 PM
  5. PD-6WCL in a 3-Way Setup
    By Kevin P. in forum Design Assistance - CAS
    Replies: 0
    Last Post: 05-01-2014, 03:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •