Trying to get the Lutron App to control and in-wall switch for our outdoor pendent. I have called support a couple of times on this issue and have been given pretty sensible things to try. After exhausting mostly all options I have decided to write a post. I summarized what I have tried below.

The switch location is by our front door and the box has three switches.

Switch A which is our landscaping lighting and outdoor post lights.
Switch B is a single pendent hanging under a covered entry way
Switch C is a pendent hanging inside our house in the foyer

Issue one - Switch A - Once the in-wall switch was installed it was immediate discoverable and programmable by the Lutron App, however, while the switch perfectly controls our outdoor post lights, the low voltage landscape lights will not turn on. Otherwise the switch and control works. I didn't install the low voltage lighting so I don't have any real specifics about what I have. I may have screwed up the transformer as I did try a caseta dimmer switch first. Currently the posts are also wrapped in Christmas lights I'm not sure if that matters. I am ok with figuring this out when it gets to be spring time. As it stands right now the post lights are working but my landscape lighting is dark.

Issue two
- Switch B - This is the main problem, and I feel like I have run the gamete as far as trouble shootin and think the only thing left to try are adjustments to the wiring of the load adaptor. I am using the in-wall switch with a Hinkley Model Shelter1328BK
Click image for larger version. 

Name:	Hinkley  Shlter 1328BK.JPG 
Views:	6 
Size:	56.0 KB 
ID:	435

Initially, I installed the swing and in operated perfectly with the wall switch control, except the app would not recognize the switch so I could program it.

Here is what I tried:

  • Deleted and reinstalled the App
    • (No Luck)

  • Restarted the Smart Bridge Pro
    • (No Luck)

  • Reset the switch to factory default multiple times with the same result
    • (No Luck x2)

  • Tried a different in-wall switch (did the same thing, worked at the wall but not the app)
    • (Frustration)

  • At the suggestion of the tech line: Connected the Lutron in-wall switch to a non-LED fixture and was able to discover it and program it from the app. Then moved the now programmed switch back to slot B. Again it worked at the switch perfectly but the app was unable to control it.
    • I was feeling really good about this one because it made so much sense but when I rewired everything I came up with the same result. Works as a wall switch but not found by the App.
    • The indicator light on the switch still flashes red

  • Tried installing the load adapter in the box at the switch. and the light LED Pendent flashed continuous. Obviously, I had wired it wrong. Because of the location of the light (Hanging outdoor pendent about 20 feet up) I really would like to avoid installing the load adapter in the junction box if possible. Is there anyway or an additional diagrams available for installing the load adaptor at the box?

This is the first of about 10 locations I plan to wire so I am trying to get this one sorted before I move on. Thanks for any suggestions.