Thanks Thanks:  0
Likes Likes:  1
Dislikes Dislikes:  0
Page 3 of 3 FirstFirst 123
Results 21 to 24 of 24

Thread: How I recovered my Luton Homeworks 4 Series system from the dead

  1. #21

    I’m having the same issue - Software request

    Quote Originally Posted by WaarrEagle View Post
    This was such a saga and I want to share for the benefit of others.

    I have a Lutron Homeworks 4 Series H4P5-H48-120 system running only lights. Over time the system became unstable, i believe due to power outages/flickers. It would "crash" and the keypads would scroll / waterfall. Years ago I figured out that you could unplug the power, flip dip switch 1, power cycle, flip dip switch 1 back, and it would come back online. This happened so many times that eventually the 12v prong broke off where I was constantly yanking power.

    It sat for several months before I got around to working on it. After much research, I uncovered the Homeworks Illumination (HWI) software and downloaded 1.65 (the latest). I soldered the 12v power prong back onto the board and got it powered up, but only to boot mode. I bought a serial -> USB cable to connect to my laptop. User randyc was super helpful in walking me through how to get a processor added to a project so I could attempt to connect. Unfortunately my primary laptop is Win 11 and the serial cable would not work. Found a laptop still running Win 10 and was able to connect to the processor in boot mode. I checked and no OS was loaded, likely from the long period of being unplugged and a bad onboard battery.

    I then used HWI 1.65 to load the OS but it still would not boot. Tried several times, hit the internet and found a couple posts on here and elsewhere about low batteries, etc. I bought a replacement battery from - this one, with leads, that exactly matches the original, and had it installed by a local shop for $50. I had to upload the OS again, but still no boot.

    Frustrated, I hit the internet again. I found a post on here saying 1.65 would not restore the OS on certain older processors. So I found a link to 1.64 and paid $10 to access a forum to download it. No change at all. Then I messaged some folks and a different guy told me I would have to use a HWI version above 1.18 and below 1.50. So I went on the hunt for 1.49. Lutron tech support was useless and would not give it to me. Found a guy with access and he shared the software. Uploaded the OS with HWI 1.49 and bam it booted right up. I then moved to 1.65 and uploaded the latest software from it, which worked great.

    So now I had it booted but I did not have a backup of the project file. My original installer was happy to talk system upgrades but went silent when I asked for the project file. Perhaps he lost it, whatever... After much trial and error, and reading the excellent HWI help files, I restored the majority of my project. Everything important works now, and I actually have control over it for the first time which is super nice.

    My only remaining issue is that certain lights do not appear to be connecting to the processor. Oddly, the LED’s on Bus 4 look different from all the others – the RX light is solid bright vs flashing. I suspect an issue with the 12v daisy chain on that bus but have not had time to investigate further.
    I now have copies of HWI 1.16, 1.49, 1.64, and 1.65. I know PM’s are disabled here but find me on Reddit and I am happy to share. There are a handful of knowledgeable folks out there willing to help but they are few.

    Major thanks to:

    User randyc on this forum for his tremendous help. His advice in the beginning enabled the whole thing to play out.

    User floridacommand on this forum for posing about the version issue, tho he totally ghosted me shortly after I made contact via another online communication channel.

    An unnamed Reddit user for providing me the 1.49 software.

    E-Bay user automatedcontrols knows his stuff. I can’t speak for his service, but I would send my processor to him in a heartbeat if I could not DIY the above. Prices sound very reasonable too.
    I have the same issue and I’m hoping you could share the softwares you used!

    My Reddit account is Brian-Maranville. This would help me tremendously. Thank you!

  2. #22
    Junior Member
    Join Date
    Sep 2023
    Hi all, I have a Series 8 processor and have done some reverse engineering on the system in order to being able to replace the programs in case of e.g., battery failure. Can maybe help also with SW and getting into the processor, in case you don't have username/password. Currently have started to replace programs in Lutron and Control4 with Home Assistant and wrote a plugin to talk to the processor over the network interface. Would be great to get in contact with other HWI owners! Pls email me WaarEagle and Brianmaranville if you still have the system. I couldn't DM you but I am available as markus on the domain over email

  3. #23
    Junior Member
    Join Date
    Nov 2023
    Hi randyc,

    I was wondering if you or anyone else in the Lutron community have come across the following issue. I have a Homewroks HWI from 2002. Had a power outage and the keypads began "waterfalling" and the system showed a "0F" code. Suspected that I had lost the OS and Project so I uploaded the OS (as I have all the backups) and after I powered down and powered back up as instructed by the terminal I get a System Error saying "OS not programmed". Not sure what my next steps should be.

  4. #24
    Junior Member
    Join Date
    Nov 2023
    Found the answer. The internal battery that is soldered to the circuit board died. During a power outage the OS system running the HWI-PM-D48-120 processor was disrupted and is lost. If there is continuous power feeding the HWI-PM-D48-120 processor then it will run with out impact to the OS and light controls. Solution is to get a UPS system and splice the power connection to the UPS directly. No longer a need for the battery connected to the circuit board.

    Reload your OS system and your project to get your system back online.

Page 3 of 3 FirstFirst 123

Similar Threads

  1. 4 Series Processor dead?
    By Lcrider in forum Troubleshooting - Legacy HW
    Replies: 9
    Last Post: 12-15-2022, 06:39 AM
  2. Homeworks Illumination - Dead HRP5-120 - What is my upgrade path?
    By 39CentStamp in forum General Discussion - Legacy HW
    Replies: 5
    Last Post: 07-20-2022, 06:15 PM
  3. Recovered file from Illumination system not opening
    By SparkyCoog in forum General Discussion - Legacy HW
    Replies: 3
    Last Post: 03-07-2021, 09:17 AM
  4. Replies: 2
    Last Post: 07-04-2019, 03:31 PM
  5. Homeworks Series 8
    By matty67 in forum Troubleshooting - Legacy HW
    Replies: 1
    Last Post: 05-07-2018, 11:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts