Thanks Thanks:  1
Likes Likes:  1
Results 1 to 4 of 4

Thread: PD-6WCL dimmer stops working when branch circuit connected

  1. #1
    Junior Member
    Join Date
    Nov 2021
    Posts
    2

    PD-6WCL dimmer stops working when branch circuit connected

    In a 3-gang switch box, I'm wiring three PD-6WCL dimmers that are controlling one light each. I have identified the hot (line) wire which is also connected to another cable that seems to power another independent switch box and lights in an adjacent room. There were three standard single-pole switches in this box previously working fine.

    When I connect the three dimmers to the hot (line) everything works as expected. When I add the branch line one of the dimmers stops working. I see one LED on the dimming indicator and it doesn't power up or switch the light. It's always the same light that doesn't work regardless of swapping switches. If I remove the branch wire everything works.

    Any advice or idea what might be going on in this situation? Thanks!

  2. #2
    Senior Member
    Join Date
    Oct 2013
    Posts
    2,188
    It sounds like you did everything correctly. First, I would check the neutral wires. You didn't touch them but sometimes just pulling stuff out of the box and putting it back in can cause something to come loose. Second, I would twist the hot and feed to the next box then add the dimmers one at a time.
    Convergence Technologies Raleigh, North Carolina
    www.convergenceusa.com

  3. Thanks halftone thanked for this post
  4. #3
    Junior Member
    Join Date
    Nov 2021
    Posts
    2
    Looks like the cause was bad or marginal wire connections. It's odd that it was so consistently affected the same switch circuit. But, I replaced all wire nut connections with WAGO 221 connectors and everything works. I know this is normally done with wire nuts, but with the amount of pig-tails and wires involved I must have not been able to have a solid connection somewhere causing the dimmer to fail.

  5. Likes randyc liked this post
  6. #4
    Senior Member
    Join Date
    Oct 2013
    Posts
    2,188
    I actually like the stab-in connectors...IF... you use the proper size!
    Convergence Technologies Raleigh, North Carolina
    www.convergenceusa.com

Similar Threads

  1. Replies: 2
    Last Post: 11-05-2021, 12:58 AM
  2. Casey’s PD-6WCL dimmer not working
    By Orchid08 in forum General Discussion - Controls
    Replies: 1
    Last Post: 03-05-2021, 11:27 AM
  3. Lutron Maestro occupancy sensor stops working after 5 minutes or so
    By Thomas5 in forum Troubleshooting - HWQS
    Replies: 1
    Last Post: 12-11-2019, 12:46 PM
  4. Pd-6wcl stops working
    By Gearboys in forum Troubleshooting - Controls
    Replies: 2
    Last Post: 05-07-2018, 10:59 AM
  5. Old iPhone app stops working after processor replacement
    By DHKaplan in forum Troubleshooting - Legacy HW
    Replies: 2
    Last Post: 07-10-2014, 11:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •