Sorry to reply so late. I had similar issues with my RA2 system and UBNT. Here are the settings that resolved the issue:

Settings/Wifi/Advanced
Optimize IoT connectivity: enable
Multicast enhancement: enable

Settings/Network/Lan/Advanced
IGMP Snooping: enable

Settings/Advanced Features/Advanced Gateway Settings
UPnP: Enable