Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: How to configure Multicast / IGMP on a Cisco SG Switch Activate Transfer Extract

  1. #1

    Smile How to configure Multicast / IGMP on a Cisco SG Switch Activate Transfer Extract

    Hello
    I have been playing around for a very long time (many months now) with my Lutron RadioRA2 system and my Cisco SG550X managed network switch. For a long time I could not get my desktop PC connected to a port on the switch to Activate / Transfer or Extract Project File with my Main Repeater making programming very inconvenient as I would have to plug directly into the Main Repeater. I would get all sorts of errors during these tasks which all was indicative of a Multicast problem with my network. I spent a lot of time researching this on the forums and google and I could find no information on what the exact settings should be which will allow this to work. Even Lutrons own networking guides do not go into sufficient detail or examples to configure network equipment. Those guides do however claim that IGMP and Multicast on managed network switches is fully supported - that was at least helpful to know that this really should work. Many installers i've spoken to have never figured this out and instead just plug directly into the main repeater, or use a dumb switch to get around this issue. After many hours of trial and error, i thought I would share what I did to fix my problems, and allow me to use a feature rich network switch with my Lutron system. Hopefully the information here can easily translate to other brands of switches as well.

    First, my Setup. I have a Cisco SG550X Gigabit PoE Managed Switch with about 100 devices on my home network. I have several VLANs configured for various purposes. Many of the devices are on a dedicated VLAN for all my IoT devices, including my computer used to program the Main Repeater, the Main Repeater itself and my Lutron Connect Bridge. I also have all sorts of other stuff like a sonos and google home on this same VLAN with the Main Repeater.

    Within the Cisco SG550X i had to configure the following Settings:

    1. My three Lutron device ports are configured as Static Access ports on the same VLAN with the rest of my IoT devices
    2. Under Multicast --> Properties:
    - Bridge Multicast filtering: Enabled (this globally enables IGMP on the switch)
    - for my Lutron VLAN, Forwarding Method for IPv4: Source Specific IP Group Address
    3. Under Multicast --> IPv4 Multicast Configuration --> IGMP Snooping
    - IGMP Snooping Status: Enabled
    - IGMP Querier Status: Disabled (this is important to disable otherwise it opens a whole other world of programming requirements for proper multicast routing between VLANs which we dont need or want here)
    - in the IGMP Snooping Table under my Lutron VLAN i have these VLAN specific settings:
    - IGMP Snooping Status: Enabled
    - MRouter Ports Auto Learn: Disabled
    - Immediate Leave: Disabled
    - Last Member Query Counter: Use Query Robustness (2)
    - IGMP Querier: Disabled
    4. Under Multicast --> IPV4 Multicast Configuration --> IGMP VLAN Settings
    - for my Lutron VLAN, i configured the Router Version to v1, although this shouldnt be necessary since there is no Multicast Routing enabled globally on this switch, but it was part of overall trial and error and is part of my final config at this point
    5. IGMP Routing and Proxy settings are all disabled
    6. Under Multicast --> Multicast Router Ports
    - every port is set to: None
    7. Under Multicast --> Forward All
    - all ports set to: none
    7. Under Multicast --> Unregistered Multicast
    - all ports set to: forwarding

    After doing this, i now see a Multicast address for the main repeater, and during the transfer process, i see a new multicast address recognized by the switch, with the two switchports (the computer and main repeater) automatically/dynamically added to that IP Multicast Group.
    Within the Lutron Main Repeater Web interface there is a noted Multicast address for the System, however, it appears that this system address is not exclusively used to complete a transfer, and instead a second IP Multicast Group address is created during the transfer process.

    Of all the settings above, i think the main settings which finally enabled all this to work was changing the forwarding method to Source Specific IP Group Address, and also turning off Immediate Leave/MRouter Port Autolearn.

    Good luck and I hope this helps you.

  2. #2

    trying again with indentations

    intentionally deleted

  3. #3
    Senior Member
    Join Date
    Oct 2013
    Posts
    1,521
    Awesome info! My network guy is going to hate you .

    I find that "sometimes" changing from Multicast to "use repeater address" (find main repeater, show advanced, system communication) helps.
    LED, Incorporated
    Raleigh, NC 27614

Similar Threads

  1. Replies: 0
    Last Post: 10-30-2017, 12:30 AM
  2. Cisco RV series routers
    By randyc in forum Troubleshooting - CAS
    Replies: 1
    Last Post: 09-07-2017, 09:52 AM
  3. Replies: 2
    Last Post: 02-06-2017, 11:29 PM
  4. 6 Button keypad 80% "broken" after de-activate and re-activate?
    By Ramias in forum Troubleshooting - RA2
    Replies: 1
    Last Post: 11-29-2016, 04:56 PM
  5. Sonicwall and multicast
    By MitchE in forum Troubleshooting - RA2
    Replies: 1
    Last Post: 03-22-2015, 08:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •