Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: PD-6ANS Running hot? is this normal?

  1. #1
    Junior Member
    Join Date
    Nov 2019
    Posts
    2

    PD-6ANS Running hot? is this normal?

    I replaced a single box switch to a PD-6ANS in an exercise room with 30 fluorescent tubs, the lights were replaced with LED equivalents. I did the math and with they should only be using about 500w, and this switch is rated for 700w. The switch runs very warm, makes me a bit nervous. It operates, but the previous switch was not warm in anyway. Is there something else I should check? Is it normal for them to get warm/hot? It's more of the screw on the face plate the get really hot. Any suggestions would be appreciated? Did I wire it wrong? There is a group and a neutral, etc. JUST FYI, Before I switched out the bulbs it was very warm, but as I took the old bulbs out it got cooler, but as I added the new LED bulbs, it got warmer again.Thanks in advance.

  2. #2
    Senior Member
    Join Date
    Oct 2013
    Posts
    1,252
    Was the original switch electronic or mechanical? Electronic switches and dimmers do get warm. You should be able to put your hand on the plastic of the device. It may feel warm but you should be able to keep it there. If you are using a plate with metal screws, those screws are connected to the heat sink and will be much warmer than the plastic.

    You can verify the load by using a clamp-on amp meter. Keep in mind the aluminum heat sink is going to be hot.

    A screwless plate will help but the plastic buttons are still going to be warm.
    LED, Incorporated
    Raleigh, NC 27614

  3. #3
    Junior Member
    Join Date
    Nov 2019
    Posts
    2
    Thank you for the reply. The buttons themselves are not hot, it's just the metal screws. The switch was a mechanical switch before hand. It was not a dimmer, just and on and off. Your response makes me feel a bit better. I will look into the screw less plates maybe.

Similar Threads

  1. Schedules set via the app are not running
    By ghurty in forum Troubleshooting - RA2
    Replies: 3
    Last Post: 11-14-2019, 09:20 PM
  2. How Do I Change Between 'Away' and 'Normal'?
    By Shandley in forum Troubleshooting - RA2
    Replies: 4
    Last Post: 03-20-2019, 09:22 AM
  3. PD-6ANS-WH Running a Fan is Flaky
    By bushes in forum Troubleshooting - CAS
    Replies: 3
    Last Post: 12-10-2017, 12:09 AM
  4. re-IP a running processor/system
    By jkvossen in forum General Discussion - HWQS
    Replies: 7
    Last Post: 08-29-2017, 11:49 AM
  5. Fixing Normal Timeclock Modes Getting Randomized in Away
    By schalliol in forum General Discussion - RA2
    Replies: 6
    Last Post: 05-16-2017, 01:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •