Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Trouble setting up Siri Integration

  1. #1
    Junior Member
    Join Date
    Jul 2015
    Posts
    5

    Post Trouble setting up Siri Integration

    I just installed my Lutron Homekit bridge. Unfortunately, this required several attempts since it could not find the bridge until it finally asked for the IP address of the Lutron Homekit bridge. After pairing the lights and Pico controllers, I am not able to set up Siri Integration. I repeatedly get a "Unable to add new home" error message. I am running Version 2.2.1 of the iOS app. Please help. Thank you.

  2. #2
    Junior Member
    Join Date
    Jul 2015
    Posts
    5

    IPad Mini 2 can connect to Siri, but IPhone 5S can not

    After some almost random attempts, I got my IPad Mini 2 connected with Siri, but my IPhone 5S which is on the same iOS 8.2 and same Apple ID can not activate Apple Homekit for Lutron.

    Quote Originally Posted by TexasBuyer View Post
    I just installed my Lutron Homekit bridge. Unfortunately, this required several attempts since it could not find the bridge until it finally asked for the IP address of the Lutron Homekit bridge. After pairing the lights and Pico controllers, I am not able to set up Siri Integration. I repeatedly get a "Unable to add new home" error message. I am running Version 2.2.1 of the iOS app. Please help. Thank you.

  3. #3
    Junior Member
    Join Date
    Sep 2014
    Posts
    18
    i would recommend upgrading to the newest version of iOS 8.4.
    Also log out and log in of your Lutron account in the Lutron App

  4. #4
    Junior Member
    Join Date
    Jul 2015
    Posts
    5

    Still no Siri integration. . . :-(

    Quote Originally Posted by sblunden View Post
    i would recommend upgrading to the newest version of iOS 8.4.
    Also log out and log in of your Lutron account in the Lutron App
    Thanks, but yes, I am already running iOS 8.4 and tried to logout and log in my Lutron account. I also reset my Lutron bridge and re-paired all my switches for a "fresh" re-installation, but still get the "home not found" message. I can control the lights from my iOS app, but still not Siri integration. Yes, I did purchase the Homekit version and it was mailed to me directly from Lutron.

    Sigh. . .

  5. #5
    Junior Member
    Join Date
    Feb 2015
    Posts
    29
    Quote Originally Posted by TexasBuyer View Post
    Thanks, but yes, I am already running iOS 8.4 and tried to logout and log in my Lutron account. I also reset my Lutron bridge and re-paired all my switches for a "fresh" re-installation, but still get the "home not found" message. I can control the lights from my iOS app, but still not Siri integration. Yes, I did purchase the Homekit version and it was mailed to me directly from Lutron.


    Sigh. . .
    Did you get a solution for this problem? I am having the same problem with Siri Integration. I get to the +Add Home screen and it won't accept any names.

  6. #6
    Junior Member
    Join Date
    Sep 2014
    Posts
    18
    Other things to try.

    1) Toggle iCloud keychain on and off in your iCloud settings
    2) Go to your Privacy Settings > HomeKit and Reset HomeKit Configuration...

    Then reset up HomeKit.

    You could also try to upgrade to 9.0.2 now that it is released.

    Another option to try is to Download the El Gato Eve App. It is a HomeKit App that allows you to control products from multiple vendors. I can control my lights with Eve. While shades are now supported in iOS 9 it doesn't seem like Lutron or El Gato apps are updated yet.

    I don't know if any of this will help, I am just giving troubleshooting suggestions.

  7. #7
    Junior Member
    Join Date
    Feb 2015
    Posts
    29
    Quote Originally Posted by sblunden View Post
    Other things to try.

    1) Toggle iCloud keychain on and off in your iCloud settings
    2) Go to your Privacy Settings > HomeKit and Reset HomeKit Configuration...

    Then reset up HomeKit.

    You could also try to upgrade to 9.0.2 now that it is released.

    Another option to try is to Download the El Gato Eve App. It is a HomeKit App that allows you to control products from multiple vendors. I can control my lights with Eve. While shades are now supported in iOS 9 it doesn't seem like Lutron or El Gato apps are updated yet.

    I don't know if any of this will help, I am just giving troubleshooting suggestions.
    Thanks for the suggestions. I tried your 1 & 2, but no luck. I got my iPad Mini 2 to work. My phone is on IOS 9.0.2 already. I have the public beta 9.1 Beta 4 on my iPad. But I don't want to risk that on my Phone. It was pretty cool having Siri turn on/off the lights.

  8. #8
    Junior Member
    Join Date
    Feb 2015
    Posts
    29
    Quote Originally Posted by msterling View Post
    Thanks for the suggestions. I tried your 1 & 2, but no luck. I got my iPad Mini 2 to work. My phone is on IOS 9.0.2 already. I have the public beta 9.1 Beta 4 on my iPad. But I don't want to risk that on my Phone. It was pretty cool having Siri turn on/off the lights.
    Problem RESOLVED!
    I just got a response from Zach at Lutron Support. He suggested I completely log out of iCloud from the Phone (keeping all settings on phone when asked). Then I waited a couple of minutes. Then logged back in to iCloud. Made sure Keychain was on. Went back into Lutron App/Siri Integration/Add a Home/Entered name of home. Success. the name was accepted. Added the Setup code. and Siri is now responding correctly. Out of all the things I tried, including the above suggestions I never though about logging out and back into iCloud. Thanks Zack, Lutron Support.

  9. #9
    Junior Member
    Join Date
    Feb 2015
    Posts
    29
    Quote Originally Posted by msterling View Post
    Problem RESOLVED!
    I just got a response from Zach at Lutron Support. He suggested I completely log out of iCloud from the Phone (keeping all settings on phone when asked). Then I waited a couple of minutes. Then logged back in to iCloud. Made sure Keychain was on. Went back into Lutron App/Siri Integration/Add a Home/Entered name of home. Success. the name was accepted. Added the Setup code. and Siri is now responding correctly. Out of all the things I tried, including the above suggestions I never though about logging out and back into iCloud. Thanks Zack, Lutron Support.
    Siri is not working again. Getting to where I just can't count on it. Tried the same procedure as before. But this time, it will not work, to allow me to Add Home.

  10. #10
    Authorized Lutron Contributor
    Join Date
    May 2013
    Posts
    313
    Try the following steps:

    1. Try unpairing the Smart Bridge from the iOS device.


    • ​Open the Lutron App and go to Settings > Siri Integration > Edit Home & Users > Remove Smart Bridge.
    • If you cannot get to screen with Remove Smart Bridge, continue to the next step.




    2. Clear HomeKit data from the Smart Bridge.


    • Pressing and holding the button on the Smart Bridge for 20 seconds will remove any HomeKit pairing data and restore network settings to defaults.


    3. Try pairing the iOS device to the Smart Bridge via the Settings > Siri Integration menu. If this fails, continue on to the next step.



    4. Try resetting all HomeKit data on the iOS device. WARNING: This will remove all pairings with other HomeKit accessories and should be done as a last resort. If you own no HomeKit accessories besides the Smart Bridge, this step can be performed without risk of losing valuable data.


    • To reset all HomeKit settings on an iOS device, go to Settings > Privacy > HomeKit and there is an option to “Reset HomeKit Configuration”​

    NOTE: If the above does not work, reset HomeKit configuration on all iOS devices you might have associated to that iCloud account.

Page 1 of 2 12 LastLast

Similar Threads

  1. Siri control of serena shades
    By malba2366 in forum General Discussion - CAS
    Replies: 16
    Last Post: 04-22-2016, 06:02 PM
  2. Trouble with 6NA Dimmer and Cree CR6
    By dinom in forum Troubleshooting - RA2
    Replies: 8
    Last Post: 11-10-2015, 08:21 AM
  3. Siri question
    By hgmobile in forum General Discussion - CAS
    Replies: 15
    Last Post: 08-14-2015, 10:41 PM
  4. Replies: 0
    Last Post: 06-20-2015, 12:39 PM
  5. Trouble Activating 6D
    By Corey in forum Troubleshooting - RA2
    Replies: 1
    Last Post: 06-06-2015, 06:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •