Thanks Thanks:  1
Likes Likes:  0
Results 1 to 4 of 4

Thread: Find Connect Bridge Update Tool

  1. #1
    Junior Member
    Join Date
    May 2019

    Find Connect Bridge Update Tool

    I recently added a Connect-BDG2 to an RA2 system for homekit compatibility. However, I got the bridge off a guy who had it sitting in a box for a while and it appears to be requesting an update using the Connect Bridge Update Tool. I cannot seem to find the tool on the website, so could anyone point me in the right direction? Or is it buried deep in the RA2 essentials tool (if so can someone point to it out as well)?


  2. #2
    Senior Member
    Join Date
    Jan 2019
    It should be found on myLutron. If you don't have an account, sign up for one using the email you used for the training and it *should* show up, under "tools". You light need to call Customer Support if that doesn't happen after a day or so.

    Many people have reported the tool refusing to function on Windows 10, but working on Windows 7. I haven't yet had the need to use the tool, but many people's issues seemed to be related to Windows 8 or 10.
    Evan Kirkhart- Home Electronics Solutions

  3. Thanks randyc thanked for this post
  4. #3
    Senior Member
    Join Date
    May 2014
    I used in on a CB Friday and it worked fine, tried on another one today and it could not find it no matter what I did, the HWQS sw couldn’t find it either even though I could ping it on the same subnet. Defaulted it, no joy, put in on a spare router with my laptop, no joy, I can ping it ut the SW or the tool can’t see it, default it again still nothing.

    I did have it working on a new job for about a month but every time I opened the activation tab it wouldn’t be discovered while the two processor would be.

    Also the led band around the thing is stupid cuz you can’t see it’s on or flashing in a lit room. For a while I though it was dead until I turned off the lights in the mechanical room.

    Guess I have to send this POS back!
    Danbury, CT

  5. #4
    Junior Member
    Join Date
    Jan 2015
    Call/chat tech support- there is a date range that can't be updated via the tool (even though its the correct model number, etc).

Similar Threads

  1. Bridge update tool
    By Lukeetal in forum Troubleshooting - RA2
    Replies: 4
    Last Post: 05-29-2019, 07:35 PM
  2. Errors while trying to find Connect Bridge
    By ITLbrittney in forum Troubleshooting - RA2
    Replies: 1
    Last Post: 03-15-2019, 01:04 PM
  3. Alexa won't find Lutron Connect Bridge Scenes
    By mikeporter2000 in forum 3rd-party Integration - RA2
    Replies: 3
    Last Post: 12-10-2018, 10:40 AM
  4. Replies: 20
    Last Post: 09-21-2018, 01:07 PM
  5. Can't find Connect Bridge
    By brewcrew0 in forum Troubleshooting - RA2
    Replies: 8
    Last Post: 01-22-2017, 08:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts