Results 1 to 2 of 2

Thread: Incrementing Event Indexes

  1. #1
    Junior Member
    Join Date
    May 2015
    Posts
    5

    Incrementing Event Indexes

    Hi,

    I’m having issues with Timeclock events on a system running firmware 8.2.

    For this installation, I am utilizing Timeclock events to trigger system operations on another RTU connected via the RS-232 port.

    My issue is related to the Timeclock’s Event Index. Every time I “Transfer” a new system configuration to the Main Repeater, the Event Indexes increments by one.

    For example, I have three Timeclock events, and my integration report shows the following
    Timeclock ID = 13
    (Event, Event Index)
    Test A, 1
    Test B, 2
    Test C, 3

    I used a Data Logger to monitor the Timeclock events as they execute.

    On my initial setup, I received the following results.
    (Event, RS-232 String)
    Test A, ~TIMECLOCK,13,5,1
    Test B, ~TIMECLOCK,13,5,2
    Test C, ~TIMECLOCK,13,5,3

    After modifying the system using Radio RA2 Inclusive, I received the following results.
    (Event, RS-232 String)
    Test A, ~TIMECLOCK,13,5,1
    Test B, ~TIMECLOCK,13,5,3
    Test C, ~TIMECLOCK,13,5,0


    As you can imagine this is causing many issues with my other RTU. Does anyone have an idea of the root cause?

  2. #2
    Junior Member
    Join Date
    May 2015
    Posts
    5
    Oops. I found an error. My second example should read the following.

    After modifying the system using Radio RA2 Inclusive, I received the following results.
    (Event, RS-232 String)
    Test A, ~TIMECLOCK,13,5,2
    Test B, ~TIMECLOCK,13,5,3
    Test C, ~TIMECLOCK,13,5,0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •